【基础】使用华为三层交换实现vlan间路由配置实战
发布日期:2021-08-28 13:15:50 浏览次数:2 分类:技术文章

本文共 4249 字,大约阅读时间需要 14 分钟。


1.    实验网络拓扑:

 

使用ENSP模拟器(版本V100R002C00 1.2.00.350

 

2.    实验需求:

属于vlan 10C1能和属于vlan 20C3C4R1通信

3.    实验步骤:

A.  IP地址及valn划分规划配置如下:

C1ip地址为192.168.10.10/24 属于vlan 10

C2:  ip地址为192.168.20.20/24属于vlan 20

C3:  ip地址为192.168.10.30/24属于vlan 10

C4:  ip地址为192.168.20.40/24属于vlan 20

Sw1:  vlan10 的网关为192.168.10.1/24

      vlan20 的网关为192.168.20.1/24

      G0/0/3属于vlan100ip201.100.100.1 /24

R1G0/0/0 ip201.100.100.2/24

B.  配置脚本:

1.     交换机SW2的配置

l 先在交换机上加VLAN 10 20,再设置接口传输模式为access

<Huawei>sy

[Huawei]vlan bat 10 20   #批量加vlan1020

[Huawei]int e0/0/1

[Huawei-Ethernet0/0/1]portlink-type ac

[Huawei-Ethernet0/0/1]port link-typeaccess  #接口类型为access

[Huawei-Ethernet0/0/1]port defaultvlan 10  #让接口属于vlan10

[Huawei-Ethernet0/0/1]inte0/0/2

[Huawei-Ethernet0/0/2]portlink-type ac

[Huawei-Ethernet0/0/2]portlink-type access

[Huawei-Ethernet0/0/2]portde 

[Huawei-Ethernet0/0/2]portdefault vlan 20

 

[Huawei-Ethernet0/0/2]intg0/0/1

[Huawei-GigabitEthernet0/0/1]port link-type trunk  #g0/0/1设为trunk 中继口

[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan 1 10 20   

#此中继接口允许vlan1 10 20的数据过,也称透传

l  display vlan 查看配置结果如下图

spacer.gifspacer.gif

l  给交换机SW2IP地址和网关,便于远程管理

因为交换机的接口是二层接口不能陪IP,所以给交换机配IP只能为其VLAN虚拟口配IP

[Huawei]int vlan 1

[Huawei-Vlanif1]ip add192.168.1.254 24

[Huawei-Vlanif1]q

 

l  在华为模拟器上通过设默认路由的方式为其设置网关

[Huawei]ip route-s 

[Huawei]ip route-static 0.0.0.0 0.0.0.0 192.168.1.1

[Huawei]

l  display ip interface brief查看各接口配置

2.交换机SW3的配置

l  为交换机SW3VLAN,接口传输模式为hybrid untagged模式,hybriduntagged模式不带标签相当于access模式,hybrid tagged模式带标签相当于trunk模式

<Huawei>sy

[Huawei]vlan bat 10 20

[Huawei]interface e0/0/3

[Huawei-Ethernet0/0/3]portlink-type hybrid   #将接口类型设为hybrid混合接口,华为三层交换机接口默认就是hybrid,属于这条命令可以不用写

[Huawei-Ethernet0/0/3]port hybridpvid vlan 10

[Huawei-Ethernet0/0/3]porthy 

[Huawei-Ethernet0/0/3]porthybrid un

[Huawei-Ethernet0/0/3]porthybrid untagged

[Huawei-Ethernet0/0/3]porthybrid untagged vlan 10  #允许vlan10 的数据过且不带标签

[Huawei-Ethernet0/0/3]inte0/0/4

[Huawei-Ethernet0/0/4]porthybrid pvid vlan 20

[Huawei-Ethernet0/0/4]porthybrid un

[Huawei-Ethernet0/0/4]porthybrid untagged vlan 20

[Huawei-Ethernet0/0/4]

 

[Huawei-Ethernet0/0/4]intg0/0/1

[Huawei-GigabitEthernet0/0/1]porthybrid pvid vlan 10

[Huawei-GigabitEthernet0/0/1]porthybrid pvid vlan 20

[Huawei-GigabitEthernet0/0/1]porthy

[Huawei-GigabitEthernet0/0/1]porthybrid t  

[Huawei-GigabitEthernet0/0/1]porthybrid tagged vlan 10 20

#允许vlan10 20的数据通过且带标签

 

l  display vlan查看vlan配置

l  给交换机vlan1配ip地址和网关,便于远程管理

[Huawei-GigabitEthernet0/0/1]intvlan 1

[Huawei-Vlanif1]ip add192.168.1.253 24

[Huawei-Vlanif1]q

[Huawei]ip route-s 

[Huawei]ip route-static 0.0.0.0 0.0.0.0 192.168.1.1

[Huawei]

结果如图

 

3.三层交换机SW1的配置

l  给交换机SW1vlan

<Huawei>sy

[Huawei]vlan bat 10 20 100

[Huawei]interface g0/0/1

[Huawei-GigabitEthernet0/0/1]portlink-type trunk

[Huawei-GigabitEthernet0/0/1]porttrunk allow-pass vlan 1 10 20

 

[Huawei-GigabitEthernet0/0/1]intg0/0/2

[Huawei-GigabitEthernet0/0/2]port hybridpvid vlan 1

[Huawei-GigabitEthernet0/0/2]port hybridpvid vlan 10

[Huawei-GigabitEthernet0/0/2]port hybridpvid vlan 20

[Huawei-GigabitEthernet0/0/2]porthybrid un 

[Huawei-GigabitEthernet0/0/2]port hybriduntagged vlan 1 10 20

 

[Huawei-GigabitEthernet0/0/2]intg0/0/3

[Huawei-GigabitEthernet0/0/3]portlink-type ac 

[Huawei-GigabitEthernet0/0/3]portlink-type access

[Huawei-GigabitEthernet0/0/3]portde

[Huawei-GigabitEthernet0/0/3]portdefault vlan 100

 

l vlan110 20 100ip地址

[Huawei-GigabitEthernet0/0/3]intvlan 1

[Huawei-Vlanif1]ipadd 192.168.1.1 24

[Huawei-Vlanif1]

 

[Huawei]intvlan 10

[Huawei-Vlanif10]

[Huawei-Vlanif10]ip add192.168.10.1 24

[Huawei-Vlanif10]

 

[Huawei-Vlanif10]int vlan20

[Huawei-Vlanif20]ip add192.168.20.1 24

[Huawei-Vlanif20]

 

[Huawei-Vlanif20]int vlan100

[Huawei-Vlanif100]ip add201.100.100.1 24

 

l  为交换机配默认路由

[Huawei]iproute-s 

[Huawei]ip route-static 0.0.0.0 0.0.0.0 201.100.100.2

结果如图:

 

4.路由器R1 的配置

l 给路由器R1接口配ip地址和默认路由

<Huawei>sy

[Huawei]int g0/0/0

[Huawei-GigabitEthernet0/0/0]ipadd 201.100.100.2 24

[Huawei]ip route-s 

[Huawei]ip route-static 0.0.0.0 0.0.0.0 201.100.100.1

l  display ip int b查看接口配置,用displayip routing-t查看路由表,结果如图


4)验证结果

因为C1C3属于vlan10C2C4属于vlan20,如果没有做vlan间路由,不同vlan间的成员是无法通信的,现在用C1 ping C2C4R1就说明vlan间路由是做成功的

l  C1 ping C2 dip192.168.20.20C4ip192.168.20.40 结果如图

l C1ping R1ip201.100.100.2 结果如图:

 

由上可得华为三层交换vlan间路由的实验成功了。

 

 欢迎加入我们的运营商网络技术交流Q群:80268245 和全国的一线工程师交流技术。


转载地址:https://blog.csdn.net/weixin_33961829/article/details/85124280 如侵犯您的版权,请留言回复原文章的地址,我们会给您删除此文章,给您带来不便请您谅解!

上一篇:Lync Server 2013企业版部署系列之八:安装lync server系统
下一篇:SCVMM2012R2 WinRM错误

发表评论

最新留言

留言是一种美德,欢迎回访!
[***.249.68.14]2022年06月05日 21时52分33秒

关于作者

    喝酒易醉,品茶养心,人生如梦,品茶悟道,何以解忧?唯有杜康!
-- 愿君每日到此一游!

最新文章